Verified Commit d16dc533 authored by azubieta's avatar azubieta

remove all multimedia support

parent 3d5de965
Pipeline #1757 failed with stage
in 2 minutes and 58 seconds
version: 1
script:
- rm -rf AppDir
- mkdir -p AppDir
- DESTDIR=AppDir make -j8 install
- for i in $(dpkg-query -L mauikit); do
if [ -d $i ]; then
mkdir -p AppDir/$i;
......@@ -22,9 +24,8 @@ AppDir:
exec_args: $@
runtime:
generator: proot
env:
PATH: '${APPDIR}/usr/bin:${PATH}'
PATH: '${APPDIR}/host_root/usr/bin:${PATH}'
PULSE_SERVER: 'unix:/run/user/$(id -u)/pulse/native'
apt:
......@@ -40,15 +41,12 @@ AppDir:
include:
# CORE DEPENDENCIES
- proot
- gettext
# BASIC QT DEPENDENCIES
- libqt5svg5
- libqt5sql5-sqlite
- libtag1v5
- libqt5websockets5
- qml-module-qtwebengine
- qt5-image-formats-plugins
# QT QUICK DEPENDENCIES
......@@ -58,35 +56,26 @@ AppDir:
- qml-module-qtquick-dialogs
- qml-module-qtquick-layouts
- qml-module-qtquick-shapes
- qml-module-qtquick2
- qml-module-qtqml*
- qml-module-qtquick2
- qml-module-qtqml-models2
- qml-module-qtqml-statemachine
- qml-module-qtqml-workerscript2
# KF5 DEPENDENCIES
- libkf5i18n-dev
- libkf5i18n5
- libkf5notifications5
- libkf5configcore5
- libkf5service-dev
- libkf5kio-dev
- libkf5service5
- kio
- libkf5configwidgets5
- libkf5syntaxhighlighting5
# OKULAR
- okular
- qml-module-org-kde-okular
# MULTIMEDIA
- libqt5multimedia5-plugins
- libqt5multimediagsttools5
- qml-module-qtmultimedia
- gstreamer1.0-x
- gstreamer1.0-alsa
- gstreamer1.0-plugins-base
- gstreamer1.0-plugins-good
- gstreamer1.0-plugins-bad
- gstreamer1.0-plugins-ugly
- gstreamer1.0-fluendo-mp3
- gstreamer1.0-pulseaudio
- libasound2-plugins
exclude:
- "*dbgsym*"
- gcc
......@@ -100,12 +89,23 @@ AppDir:
files:
exclude:
- usr/lib/x86_64-linux-gnu/gconv
- usr/include
- usr/share/man
- usr/share/doc
- usr/share/doc/*/README.*
- usr/share/doc/*/changelog.*
- usr/share/doc/*/NEWS.*
- usr/share/doc/*/TODO.*
- lib/systemd
- etc/systemd
- usr/share/perl*
- usr/bin/systemd*
- usr/bin/dpkg*
- usr/bin/python*
- usr/bin/perl*
- usr/bin/*-linux-gnu-*
- usr/lib/python*
- usr/lib//x86_64-linux-gnu/perl*
AppImage:
arch: "x86_64"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment