Verified Commit 4b7fd571 authored by azubieta's avatar azubieta

remove unrequired dependencies

parent fd519cbb
Pipeline #1037 failed with stage
in 6 minutes and 26 seconds
......@@ -20,20 +20,12 @@ appimage() { # docker-image: ubuntu:14.04
install_build_deps_appimage() {
apt-get update -qq
apt-get -y --force-yes install curl git vim-common
#apt install build-essential qt5-default libqt5websockets5-dev
#apt -y install cmake automake libtool pkg-config wget desktop-file-utils libglib2.0-dev libcairo2-dev libssl-dev libcurl3 libcurl4-openssl-dev libxpm-dev
apt-get -y --force-yes install libfontconfig1 libfreetype6 libssl1.0.0 zlib1g unzip p7zip unar
apt-get -y --force-yes install software-properties-common
apt-get -y --force-yes install curl wget git vim-common software-properties-common
add-apt-repository -y ppa:beineri/opt-qt-5.12.3-xenial
echo 'deb http://download.opensuse.org/repositories/home:/TheAssassin:/AppImageLibraries/xUbuntu_16.04/ /' > /etc/apt/sources.list.d/curl-httponly.list
curl -fsSL https://download.opensuse.org/repositories/home:TheAssassin:AppImageLibraries/xUbuntu_16.04/Release.key | apt-key add -
apt-get update -qq
apt-get -y --force-yes install build-essential mesa-common-dev libglu1-mesa-dev qt512base qt512websockets
apt-get -y --force-yes install build-essential qt512base qt512wayland qt512websockets desktop-file-utils libgl1 libdrm-dev mesa-common-dev libssl-dev libtool automake pkg-config libglib2.0-dev libcairo2-dev
curl -fsSL https://github.com/Kitware/CMake/releases/download/v3.13.3/cmake-3.13.3-Linux-x86_64.tar.gz | tar -xz --strip-components=1 -C /
apt-get -y --force-yes install automake libtool pkg-config wget desktop-file-utils libglib2.0-dev libcairo2-dev libssl-dev libcurl3 libcurl4-openssl-dev libxpm-dev
}
build_appimage() {
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment