Unverified Commit 62f2fdda authored by akiraohgaki's avatar akiraohgaki Committed by GitHub
Browse files

Merge pull request #49 from opendesktop/develop

Develop
parents a3047f24 a462e589
......@@ -57,7 +57,7 @@ $(TARGET)-linux-x64: ocs-manager
ocs-manager:
$(MKDIR) $(build_tmpdir)
git clone https://github.com/opendesktop/ocs-manager.git -b release-0.6.2 --single-branch --depth=1 $(build_tmpdir)/ocs-manager
git clone https://github.com/opendesktop/ocs-manager.git -b release-0.6.3 --single-branch --depth=1 $(build_tmpdir)/ocs-manager
cd $(build_tmpdir)/ocs-manager ; \
./scripts/package build_appimage
$(INSTALL_PROGRAM) `find "$(build_tmpdir)/ocs-manager" -type f -name "ocs-manager*-x86_64.AppImage"` $(srcdir)/bin/ocs-manager
{
"name": "opendesktop-app",
"version": "3.1.2",
"version": "3.1.3",
"lockfileVersion": 1,
"requires": true,
"dependencies": {
......
{
"name": "opendesktop-app",
"productName": "Opendesktop App",
"version": "3.1.2",
"_versioncode": 16,
"version": "3.1.3",
"_versioncode": 17,
"_releaseMeta": "https://github.com/opendesktop/opendesktop-app/raw/master/release.json",
"description": "Opendesktop Official App.",
"keywords": [
......@@ -18,7 +18,7 @@
"scripts": {
"start": "electron .",
"debug": "electron . --debug",
"package": "electron-packager . opendesktop-app --platform=linux --arch=x64 --out=dist --overwrite --ignore='^/(\\.gitignore|\\.travis\\.yml|Makefile|README\\.md|release\\.json|desktop|launcher|pkg|scripts|appimagebuild|appimagetool\\.AppImage|squashfs\\-root|build_.+)($|/)'"
"package": "electron-packager . opendesktop-app --platform=linux --arch=x64 --out=dist --overwrite --ignore='^/(\\.gitignore|\\.travis\\.yml|Makefile|README\\.md|release\\.json|desktop|launcher|pkg|scripts|appimagebuild|appimagetool|squashfs\\-root|build_.+)($|/)'"
},
"dependencies": {
"electron-store": "1.3.0",
......
#!/bin/bash
PKGNAME='opendesktop-app'
PKGVER='3.1.2'
PKGVER='3.1.3'
PKGREL='1'
curl -fsSL -o appimagetool https://github.com/AppImage/AppImageKit/releases/download/continuous/appimagetool-x86_64.AppImage
......
......@@ -15,7 +15,7 @@ ci_appimage() { # docker-image: ubuntu:14.04
apt -y install curl git
#apt -y install build-essential qt5-default libqt5websockets5-dev
#apt -y install cmake libssl-dev libcurl3 libcurl3-gnutls libcurl4-gnutls-dev libxpm-dev
apt -y install libfreetype6 libssl1.0.0 zlib1g unzip p7zip unar
apt -y install libfontconfig1 libfreetype6 libssl1.0.0 zlib1g unzip p7zip unar
apt -y install software-properties-common
add-apt-repository -y ppa:beineri/opt-qt594-trusty
......@@ -23,7 +23,7 @@ ci_appimage() { # docker-image: ubuntu:14.04
curl -fsSL https://download.opensuse.org/repositories/home:TheAssassin:AppImageLibraries/xUbuntu_14.04/Release.key | apt-key add -
apt update -qq
apt -y install build-essential libfontconfig1 mesa-common-dev libglu1-mesa-dev qt59base qt59websockets
apt -y install build-essential mesa-common-dev libglu1-mesa-dev qt59base qt59websockets
curl -fsSL https://cmake.org/files/v3.10/cmake-3.10.2-Linux-x86_64.tar.gz | tar -xz --strip-components=1 -C /
apt -y install libssl-dev libcurl3 libcurl3-gnutls libcurl4-gnutls-dev libxpm-dev
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment