Fixing AppImage Deploy

parent d2ceafc1
Pipeline #1787 passed with stage
in 12 minutes and 1 second
......@@ -30,16 +30,40 @@ AppDir:
- libqt5quickwidgets5
- qml-module-qtquick2
- qml-module-qtquick-dialogs
- qml-module-qtmultimedia
- libqt5multimedia5-plugins
- gstreamer1.0-libav
- qml-module-qtmultimedia
- gstreamer1.0-x
- gstreamer1.0-alsa
- gstreamer1.0-plugins-base
- gstreamer1.0-plugins-good
- gstreamer1.0-plugins-bad
- gstreamer1.0-plugins-ugly
- gstreamer1.0-fluendo-mp3
- gstreamer1.0-pulseaudio
- libasound2-plugins
# the following X libs are not resolved by apt
- libxrender1
- libxcursor1
exclude:
# there is no reason to be bundled
- perl
- perl-base
- perl-modules
# graphics sctack (excluded to allow running in system with non-common graphic cards)
- libdrm2
- libgl1
- libgl1-mesa-dri
- libegl1
- libdrm2
- libegl1-mesa
# fontconfig (if included the app crashes on archlinux)
- fontconfig
- fontconfig-config
- libfontconfig1
- libfreetype6
files:
exclude:
......@@ -51,10 +75,6 @@ AppDir:
- usr/share/doc/*/TODO.*
- usr/include
runtime:
env:
PATH: '"$APPDIR"/usr/bin:"$PATH"'
test:
debian:
image: debian:stable
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment